Degraded performance / intermittent failures with Box services (partner incident)

Incident Report for mxHero, Inc.

Resolved

Box has been remediating the underlying issue, and we have observed stable and normal operation across all services using Box for an extended period. We are not seeing any errors or abnormal behavior on our side.

Based on this sustained stability, we are closing this incident. We will continue routine monitoring, and if any new issues are detected, we will reopen a status notification accordingly.
Posted Feb 25, 2026 - 00:26 UTC

Investigating

We are observing a third-party incident affecting Box services used by some customers through our integration. This is not an issue with our platform, but it may impact organizations that rely on Box API / SSO / related Box services. We are actively monitoring Box’s status and will provide updates here.

https://status.box.com/incidents/yb6gsksvbkzf

Customer impact:
Intermittent failures or timeouts when calling Box APIs (uploads/downloads, search, content preview).

Scope: Customers/tenants that use Box via our services.

Workaround: No direct workaround available on our side while Box resolves the incident. If possible, retry failed operations with backoff; avoid high-volume bulk jobs until service stabilizes.

What we’re doing: Monitoring Box status, tracking error rates/latency on our integration points, and validating recovery as Box applies fixes.
Posted Feb 25, 2026 - 00:11 UTC