Some emails had a delay in Archiving address processing
Incident Report for mxHero, Inc.
Resolved
This incident has been resolved.
Posted Oct 04, 2023 - 20:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We expect around 4 hours to process the full list of emails delayed.
Posted Oct 04, 2023 - 18:20 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 04, 2023 - 17:49 UTC
Investigating
We have detected some delay in archiving address and we are taking actions. No email is lost, we are just experiencing some hours delay in archiving address processing.
Posted Oct 04, 2023 - 14:45 UTC
This incident affected: Platform Applications.