Verification is currently underway for the maintenance items.
Posted Nov 14, 2024 - 12:52 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2024 - 12:35 UTC
Scheduled
We are in the process of updating mxHERO! A maintenance window has been scheduled to facilitate the deployment of new security features and software updates for mxHERO. This update is expected to be non-impacting and is projected to last approximately 2 hours.