Some emails had a delay in the delivery
Incident Report for mxHero, Inc.
Postmortem

The root cause has been identified. An intermittent node alarm may have resulted in email processing delays for some clients.  For delays beyond 10 minutes, mxHERO may have allowed normal processing until node restoration to preclude email processing impacts for customers.

Posted Feb 17, 2023 - 13:40 UTC

Resolved
Our operations team received automated alerts about delays in the delivery of some emails. The incident has been resolved and now we're regularly servicing. Our engineering team is investigating the root cause of the issue, which seems to be related to a problem with the underlying host of some of the application instances. All pending messages were already delivered. No emails have been lost during the occurrence, but only had an additional delay in the delivery process.
Posted Feb 17, 2023 - 12:14 UTC
This incident affected: Email Delivery Service.