Email Processing Delays
Incident Report for mxHero, Inc.
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 00:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 29, 2024 - 23:45 UTC
Identified
We have identified an abnormal load on the system, and our team is actively working on implementing remediation measures. Our top priority is to address this situation promptly and restore the normal functioning of the system. We appreciate your patience and understanding as we work towards resolving the issue. If there are any further updates or changes, we will keep you informed.
Posted Feb 29, 2024 - 23:01 UTC
Investigating
We are monitoring a recent spike of network issue and the system is working on recovery. Some emails are been rejected and emails system will again retry them. We appreciate your patience as we work to gather more details and provide further insights into the current status.
Posted Feb 29, 2024 - 22:35 UTC
This incident affected: Email Delivery Service.