Delay on email delivery
Incident Report for mxHero, Inc.
Resolved
The incident has been resolved.
Posted Mar 09, 2020 - 21:21 UTC
Update
We are continuing to investigate this issue.
Posted Mar 09, 2020 - 17:54 UTC
Investigating
Emails are taking longer than expected for delivery. Our engineering team is currently investigating.
Posted Mar 09, 2020 - 17:52 UTC
This incident affected: Email Delivery Service.