Box.com outage
Incident Report for mxHero, Inc.
Resolved
Box.com has recovered the services.
Posted Sep 12, 2019 - 21:50 UTC
Update
Due Box.com outage, customers using this integration might have messages delayed or with attachments delivered as is. More information at https://status.box.com/. The mxHero team continues to monitor this condition.
Posted Sep 12, 2019 - 16:43 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 12, 2019 - 16:42 UTC
This incident affected: Email Delivery Service, Platform Applications, and Client Extensions.