Delay on messages being processed by Email Sync
Incident Report for mxHero, Inc.
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 19:45 UTC
Investigating
We are currently investigating some delay on messages retrieved by the Email Sync application.
Posted Feb 12, 2020 - 17:46 UTC
This incident affected: Platform Applications.